Electrical/Lights

General topics.

Moderators: notoptoy, S Allen, Solex68, bmccarthy67

jbarnish
Roadster Newby
Posts: 16
Joined: Thu Feb 06, 2020 4:00 pm
Location: New Jersey
Model: 1500/1600
Year: High Windshield-68-70

Electrical/Lights

Post by jbarnish »

Brake Lights and turn signals didn't work but all lights came on when i turned on the headlights. cleaned all the connectors and everything works great besides the brake safety lamp will not turn off. 4-point connector (near master cyl) with the black hot was partially melted which i'm assuming was the original issue. suggestions?
jbarnish
Roadster Newby
Posts: 16
Joined: Thu Feb 06, 2020 4:00 pm
Location: New Jersey
Model: 1500/1600
Year: High Windshield-68-70

Re: Electrical/Lights

Post by jbarnish »

i already operated the stop lamp switch on and off numerous times.
User avatar
redroadster
Roadsteraholic
Posts: 1634
Joined: Tue Mar 12, 2013 10:58 am
Location: KCMO
Model: 1500/1600
Year: High Windshield-68-70

Re: Electrical/Lights

Post by redroadster »

I'd check and improve the grounds
The high amp of the headlines likely fixing the weak ground or maybe in the relay
C.Costine
Roadster Nut-Site Supporter
Posts: 1666
Joined: Fri Feb 13, 2015 8:08 pm

Re: Electrical/Lights

Post by C.Costine »

jbarnish wrote: Sun Aug 01, 2021 3:08 pm Brake Lights and turn signals didn't work but all lights came on when i turned on the headlights. cleaned all the connectors and everything works great besides the brake safety lamp will not turn off. 4-point connector (near master cyl) with the black hot was partially melted which i'm assuming was the original issue. suggestions?

Print-off your circuit diagram and start tracing wires out.
located in Chester NH
1967 1600 in restoration
2013 Arctic Cat F-1100 turbo
Ford F-350 6.0
Ford 9000 puller, Ford 960 puller, Ford 901show, Ford 971 worker, Oliver 70 waiting its turn