I broke-ith a switch-ith

General topics.

Moderators: notoptoy, S Allen, Solex68, bmccarthy67

User avatar
Mattk
Roadster Nut-Site Supporter
Posts: 585
Joined: Mon Oct 28, 2013 1:49 pm
Location: DFW, TX
Model: 2000
Year: High Windshield-68-70

I broke-ith a switch-ith

Post by Mattk »

Well with anything, it seems, I broke something with trying to “fix” it. I’m hoping that someone can help me with this. I have tried a few times to fix it but it’s toast.
031741DC-2DCB-41EB-A365-40F67FD78DED.jpeg
It’s is the switch pictured. Actually it’s the board that the wires are soldered to in the picture. It is the switch in the column of a 69.

Please help

Thanks
Matthew
You do not have the required permissions to view the files attached to this post.
MattK
User avatar
SLOroadster
Roadsteraholic
Posts: 5292
Joined: Sun Dec 08, 2002 2:53 am
Location: Napa Ca

Re: I broke-ith a switch-ith

Post by SLOroadster »

Been there, done that. I think I used JB Weld to glue the board back together. It wasn't pretty, but it worked.

Will
Sorry, I find modern engine swaps revolting. Keep your G, R, or U series in your Roadster!
DAC21
Roadster Fanatic-Site Supporter
Posts: 536
Joined: Tue Sep 15, 2020 7:44 am
Location: California
Model: 1500/1600
Year: Low Windshield-64-67.5

Re: I broke-ith a switch-ith

Post by DAC21 »

I'd guess there are a couple traces on the back side of the board. Confirm there good, if not, you should be able to solder a jumper wire to re-establish the circuit. Maybe even just a dab of solder will do it. JB weld up the crack, or two part epoxy specifically for plastic. Good luck.
1967 1600 in waiting SPL311-09002 / R-28178
2018 Hyundai Elantra GT Sport Ultimate
User avatar
Mattk
Roadster Nut-Site Supporter
Posts: 585
Joined: Mon Oct 28, 2013 1:49 pm
Location: DFW, TX
Model: 2000
Year: High Windshield-68-70

Re: I broke-ith a switch-ith

Post by Mattk »

Well thank you gentlemen! Busted out the JB Weld and glued it. Nope it’s not pretty but it is working. Getting the little ball back into place was a bitch but I got it after a few tries. Thank again.
MattK